GeoPDF General FAQ
#500 What is the GeoPDF format? 
The GeoPDF format is an extension to Adobe's PDF 1.3 and higher specification enabling GIS functionality within standard PDF files.
#501 Who needs to use the GeoPDF format?
The GeoPDF file format was developed from the ground up to be used by the non-GIS professional. The GeoPDF format was developed by TerraGo Technologies for the efficient distribution and communication of rich spatial data to anyone who needs to view, review, verify, update or print it. Because GeoPDF are highly compressed and encapsulated files, they are smaller, faster and easier to transmit than GIS data sets, without the overhead associated with typical GIS spatial data sets (or the management of database tables, external links and dependencies). With GeoPDF, publishers of spatial data can select the specific spatial data they want recipients to see and can publish GIS source files into a single GeoPDF file. 

GeoPDF files are not a replacement for native GIS formats. GIS Professionals still need the original files for editing or updating spatial data. However, GeoPDF files enable non-GIS professionals, field technicians, business executives and their colleagues to utilize rich spatial information and spatial intent provided by the GIS team. Users can view, measure, mark up, track changes, integrate reviews and print GeoPDF files with the free* and ubiquitous Adobe Reader and TerraGo's free plug-in GeoPDF Toolbar.

#502 How much does GeoPDF cost?
Viewing and printing GeoPDF files is free. GeoPDF publishing capabilities are integrated into several leading GIS applications. GeoPDFs are created with TerraGo Technologies MAP2PDF Publishing Software Suite of Products. MAP2PDF enables users of GIS applications to create GeoPDF files. Viewing and printing GeoPDF files is free with the ubiquitous Adobe Reader and TerraGo's GeoPDF Toolbar.

#503 What software do I need to publish GeoPDF files?
You need one of the following TerraGo Technologies MAP2PDF software publishing tools:

· From ESRI ArcMap, MAP2PDF for ArcGIS 

· From Intergraph GeoMedia, MAP2PDF for GeoMedia 

· From Intergraph DCS, MAP2PDF for DCS 

· From Adobe's Acrobat, MAP2PDF for Acrobat 

#504 What software do I need to view GeoPDF files?
You need the FREE Adobe Reader 6 or 7 to view GeoPDF files. To utilize the rich and robust GIS functionality, you will also need GeoPDF Toolbar, TerraGo Technologies FREE plug-in for Adobe Reader 6, 7 & 8..

#505 Is the GeoPDF file format secure?
GeoPDF files include only what the publisher intends to share. Database joins, attribute and/or object data and properties are not included unless published by the GIS user. In addition, GeoPDF leverages existing PDF security, such as password protection, digital signatures and enterprise document management policies that can provide and control the following: 

· Confidentiality - Control who has access to the document. 

· Authorization - Control what someone can do with the document. 

· Accountability - Track what someone does with the document. 

· Integrity - Show whether a document has been altered. 

· Authenticity - Verify the source of the document. 

#506 Can several MAP2PDF products be installed on the same machine at the same time?
Yes, You can install as many MAP2PDF products on your machine that you have corresponding products for.  Therefore, if you have Adobe Acrobat versions 6, 7 and 8 as well as Adobe Reader versions 6, 7 and 8, along with ArcGIS version 9 and GeoMedia Version 6, you could have 6 MAP2PDF applications all installed on one machine at the same time, without conflict. 

#507 How do I publish my entire spatial database to GeoPDF?
Accomplish this by publishing a single page GeoPDF file, a multi-page GeoPDF file or a set of GeoPDF files that are tightly connected using standard Adobe bookmark and hyper-linking navigation.

#508 Are there any size limitations to GeoPDF?
Due to the current performance limitations of Adobe Acrobat and Reader it is recommended through best practices to limit the number of joined objects to 32,000 objects or less per GeoPDF page. 

#509 How accurate or precise is a GeoPDF file?
GeoPDFs are published views of the GIS data and are as precise as the source data.  The precision is set by the creator of the PDF to an appropriate precision for the scale of map created. Take into consideration the following precision metrics: 

The precision of what is drawn in a GeoPDF
The implementation limit in Adobe is an effective resolution of 720,000 dots per inch.

The precision of the coordinate readout in a GeoPDF
The Coordinate readout is limited to the pixels on the screen 
(mouse location). This is limited by the Windows screen resolution and 
the zoom level. Most screens have a resolution of 72 dpi (however, it's not uncommon for a notebook to have a resolution of 100 dpi). Adobe only zooms to 6400% or 64x. 72x64 = 4,608 dots per inch. For a 1:50,000 map each pixel is about 0.904 feet, therefore the coordinate readout would change by that much each time a pixel is changed. On a 1:5000 map, each pixel is about 1.08 inches.

The precision of what can be viewed in a GeoPDF
Effectively the same as Precision 2. 

The precision of our numbers used for the calculations.
There are no discernible limits. GeoPDF supports 64 bit precision.

The precision of data collected from external devices. 
If data is collected by clicking on a map, it's the 4,608 dots per inch limit. However, any external device used for collecting data, is not limited to fixed point notation and can maintain the full resolution of the information collected. 

#510 What is the difference between the GeoPDF and the PDF format?
GeoPDF was created to extend Adobe's PDF file format for spatial or location based applications. GeoPDF fully complies with Adobe's PDF 1.5 and 1.6 specification, but allows the transformation of PDF files to be moved from simple paper space coordinate systems to real world complex coordinate systems. This allows for the transfer or extraction of object data, redlines, markups, multimedia and notes to be transferred to and from GIS applications.

#511 How do the GeoPDF and PMF formats differ? 
GeoPDF utilizes the defacto standard PDF file format to publish and distribute GIS data using the ubiquitous Adobe platform - currently available on over 1 billion computers. GeoPDF is a self contained file which is normally much smaller than PMF file data sets-often 1/3 to 1/10 the size. GeoPDF files transmit faster and can be emailed easier without hitting system limits. The GeoPDF used in conjunction with the Adobe platform supports advanced markup, measurement, and workflow features not available with PMF. GeoPDF's are capable of markup, redline, remarks, timestamps, history, and status information and supports other standard business and engineering documentation to improve communication, collaboration, commands and controls common picture.

#512 Is GeoPDF a TerraGo file format?
TerraGo Technologies developed  the GeoPDF file format, it is currently a registered trademark. This technology is currently patent pending and can be created using  MAP2PDF publishing software licensed from TerraGo Technologies or its partners.

#513 Can I embed a GeoPDF file into other PDF files?
GeoPDF is a fully compliant extension to the Adobe PDF 1.5 and 1.6 specification. Just as a user can attach multiple PDF files created from disparate applications, a user could also attach or embed GeoPDF files in the same manner. 

#514 Can I embed a GeoPDF into a website or Microsoft Office application?
GeoPDF files integrate into any application that supports PDF files. 

#515 How do I view GeoPDF files?
GeoPDF files are viewable by any PDF file viewer. TerraGo Technologies recommends using either Adobe Acrobat Standard or Professional or the FREE Adobe Reader with TerraGo Technologies MAP2PDF for Acrobat or FREE GeoPDF Toolbar to experience the full and robust GIS functionality.

#516 Is the GeoPDF file format supported by Adobe?
TerraGo Technologies is a certified business partner of Adobe Systems and is recognized by Adobe as the world wide expert for developing and implementing GIS applications on top of the Adobe Intelligent Document Platform.

#517 Do users have to have GeoPDF Toolbar installed to view GeoPDF files?
Users do not have to install GeoPDF Toolbar to view GeoPDF files. However, it is highly recommended to install the FREE toolbar to utilize the rich and robust GIS functionality inside Adobe Reader. 

#518 What are the minimum hardware requirements to view a GeoPDF?
· Intel® Pentium® processor 

· 128MB of RAM min, 256 MB or greater recommended 

· 100 MB of available hard-disk space recommended 


#519 Can users add comments and/or other markups into a GeoPDF?
Users can add a wide variety of comments and/or markups into the GeoPDF file utilizing Adobe's standard markup and collaboration tools. These include:

· Notes 

· Comments 

· Stamps/Symbols 

· Pictures 

· Drawing Tools - line, polyline and  polygon 

· Digital Signatures 

· Pen based tablet writing 

If enabled for GeoMarks, users can add points, lines, polylines and stamps which can be exported out to shape files. Shape files can then be imported back into your GIS application. 

#520 Can my users send their comments and/or markups to other users?
Users can easily send their comments and/or other markups to other users. This can be accomplished through email or a network connection by either docking or real time updates. GeoPDF supports Adobe's standard .fdf file format and .shp file format. 

#521 I don't see my GIS system listed as being able to create GeoPDFs. How can I find out when it will be available? 
TerraGo Technologies will be supporting most major GIS systems in the near future. To find out when your GIS application will be supported, it is recommended that you sign up for Geo2Go, our quarterly news letter, to stay abreast of new product releases. Send requests to support@terragotech.com.

#522 Why should I use GeoPDF instead of using a free viewer available from my GIS vendor such as ArcReader? 
TerraGo Technologie's FREE GeoPDF Toolbar turns Adobe Reader into a robust GIS viewing, markup and enterprise collaboration tool that requires no support and very little training. Most people already know how to use PDF's and the additional functionality in GeoPDF's is intuitive and easy to learn. This solution leverages functions already built into Adobe, including markup and collaboration tools. You'll have everyone utilizing GIS data in no time and you'll probably have fewer special requests for map creation taking up your time. With over 1 billion installed Adobe Reader users, the answer is quite simple on why you would utilize this conduit to publish your GIS information to anyone - anywhere.

#523 Are other PDF formats available that provide georegistered information?
No, TerraGo Technologies developed GeoPDF and owns the associated technology.

#524 How does GeoPDF relate to web based mapping services like Google and Yahoo local?
GeoPDF files compliment web based mapping applications. GeoPDF's, just like PDF files, can be used in both a connected or disconnected mode. Therefore, if a user is not connected to the net, the application is still functional. 

#525 Why should I use a GeoPDF if I already have a free viewer like ArcReader? 
GeoPDF files utilize the free and ubiquitous Adobe Reader platform. Therefore, when you combine GeoPDF files with other types of business critical documentation that is already in PDF file format: (Forms, spreadsheets, support and help files), the user only has to use one support application and IT. Since this application is Adobe Reader, the user already is familiar with GeoPDF files and IT already supports it.

#526 Who is using GeoPDF?
GeoPDF's are being used by the following:

US Government
1. DOD (Dept. of Defence) 

a. Army 

b. Army Corp of Engineers 

c. Air Force 

d. Navy 

e. Marines 

f. Coast Guard 

g. Border Patrol 

2. National Security 

a. NGA 

b. Department of State 

c. CIA 

d. NSA 

3. Civil 

a. FAA 

b. NOAA 

c. National Parks 

d. Forest Service 

e. USGS 

f. USDA 

g. Census 

Several International Governments
1. Australia 

2. Canada 

3. Finland  

Other
1. State and Local Governments 

2. DOT's 

3. Gas, Oil and Electric Utilities 

4. Commercial Service Providers back to top 

 

#527 What applications are currently available to publish GIS files?

· MAP2PDF for GIS supports: 
· ESRI ArcMap 9.x 

· Intergraph GeoMedia 6.x 

· Intergraph DCS 

· Support for other major GIS applications are coming soon! 

· MAP2PDF for Acrobat supports: 
· Acrobat 6, 7 & 8

#528 If I purchase a product from TerraGo Technologies, what is included with my maintenance fee?

Maintenance includes all upgrades to newly released versions of the product purchased as well as unlimited Technical Support for year after your original purchase date.

#529 How does TerraGo currently license their MAP2PDF products?
Currently, all MAP2PDF software operates on node-locked licensing. This means that if you purchase a single license of a MAP2PDF product, it may only be activated on a single machine.

MAP2PDF for ArcGIS

#3000 What software do I need to view GeoPDF files?
You need the FREE Adobe Reader 6 or 7 to view GeoPDF files. To utilize the rich and robust GIS functionality, you also need TerraGo Technologies FREE GeoPDF Toolbar. 

#3001 Can my users send their comments and/or markups to other users?
Users can easily send their comments and/or other markups to other users. This can be accomplished through email or a network connection by either docking or real time updates. GeoPDF supports Adobe's standard .fdf file format and the .shp file format. 

#3002 Can several MAP2PDF products be installed on the same machine at the same time?
Yes, You can install as many MAP2PDF products on your machine that you have corresponding products for.  Therefore, if you have Adobe Acrobat versions 6 & 7 as well as Adobe Reader versions 6 & 7, along with ArcGIS version 9 and GeoMedia Version 6, you could have 6 MAP2PDF applications all installed on one machine at the same time, without conflict. 

#3003 Why am I unable to check my MAP2PDF for ArcGIS extension on?
If you are using ArcGIS 8.x, the MAP2PDF extension appears in the extensions list, but you are unable to turn it on. MAP2PDF for ArcGIS is only available for ArcGIS version 9.x and above.

#3004 How can I reduce the output file size of my GeoPDF when exporting from ArcGIS?
Use the following options to help reduce your output file size:

1. Lower your resolution (dpi) through the Options drop down menu within the Export Map dialog
2. Use Deflate as the Image Compression option from the Options drop down menu within the Export Map dialog
3. Convert street data to route data
4. Reduce the number of object data/annotations present for export
5. Reduce the amount of data being exported

#3005 Why is the Object data tool recognizing data as offset from the actual feature?
Due to an ESRI limitation, sometimes projection parameters are lost after exporting to GeoPDF causing the Object data tool to show attribute data as offset from the actual feature it relates to. Resetting the projection parameters in ArcGIS and exporting the file to a GeoPDF typically resolves the issue.  This problem can also happen after increasing your page size. Follow the steps below to refresh the projection of the file:

1. Open the MXD in ArcMap
2. Right-click on the data frame and click the Properties option.
3. Click the Coordinate System tab.
4. Click on each folder again to redefine the coordinate system, then click OK. 
5. Save the MXD.
6. Export to GeoPDF again.

#3006 Why do I recieve the following error message upon exporting to a GeoPDF from ArcGIS?

insertLayers: stream i/o error

This error message is given when the resolution for the output GeoPDF has been set too high. Reduce your dpi setting upon exporting the file within the Options drop down settings within the Export Map dialog.

#3007 Why is my Request Code non-existent after entering my License Key within the MAP2PDF software activation dialog?You must have administrative privileges on the machine in order to produce the Request Code. Otherwise, the area will be empty within the activation dialog. Have your system administrator log in and generate the Request Code on your behalf or have your administrator temporarily provide you with administrative privileges to complete the registration process.

#3008 How Can I Modify the ESRI DS Map Book Sample Script to Export to GeoPDFs?
Visual Basic and knowledge of how to modify infomation within Visual Basic is required to modify and use this sample script.
1. Download ESRI’s Developer Sample from the following web site:

http://edndoc.esri.com/arcobjects/9.0/default.asp?URL=/arcobjects/9.0/Samples/
Cartography/Map_Production/DSMapBook/DSMapBook.htm
2. Unzip the contents just downloaded into a desired folder.

3. Double-click the INSTALL.bat file to run the DS Map Book installation.

*At this point, you are able to use the DS Map Book sample within ArcGIS. However, the export will not include the 

     GeoPDF file option.
4. Right-click on the frmExport.frm file within the Project window.

5. Choose the View Code option.

6. Perform a replace where you find “PDF” (case sensitive) and globally replace it with “GeoPDF”.

    *Make sure the Match Case option is selected.
7. Click the Replace All button.

8. Click the Project menu > References option.

9. Browse to and check on the MAP2PDF for ArcGIS 1.1 Type Library.

10. Click the File menu > Make DSMapBookPrj.dll option

#3009 How can I get my inserted Microsoft Word or Excel files to export from my ArcMap Layout into the GeoPDF?
Apparently if you insert either a Word or Excel file into your ArcMap Layout via the Insert > Object option, the document or table does not export correctly into the GeoPDF. As a temporary workaround, simply copy and paste the document or table into the ArcMap Layout and then attempt to export to the GeoPDF file format. This has proven to be a successful workaround minus any special formatting done to the borders or cells within an Excel file. 

MAP2PDF for Acrobat FAQ

#2000 What software do I need to view GeoPDF files?
You need the FREE Adobe Reader 6 or 7 to view GeoPDF files. To utilize the rich and robust GIS functionality, you also need TerraGo Technologies FREE GeoPDF Toolbar. 

#2001 What software do I need to enable markup, redline and commenting in Adobe Reader? 
You need Adobe Acrobat 7 Professional to enable GeoPDF's or PDF files for markup, redline and commenting in Adobe Reader 6 or 7. 

#2002 What are the minimum hardware requirements to view a GeoPDF file?

· Intel® Pentium® processor 

· 128MB of RAM min, 256 MB or greater recommended 

· 100 MB of available hard-disk space recommended 

#2003 Can users add comments and/or other markups into a GeoPDF?
Users can add a wide variety of comments and/or markups into the GeoPDF file utilizing Adobe's standard markup and collaboration tools. These include:

· Notes 

· Comments 

· Stamps/Symbols 

· Pictures 

· Drawing Tools - line, polyline and  polygon 

· Digital Signatures 

· Pen based tablet writing 

#2004 Can my users send their comments and/or markups to other users?
Users can easily send their comments and/or other markups to other users. This can be accomplished through email or a network connection by either docking or real time updates. GeoPDF supports Adobe's standard .fdf file format and .shp file format. 

#2005 Can several MAP2PDF products be installed on the same machine at the same time?
You can install as many MAP2PDF products on your machine that you have corresponding products for.  Therefore, if you have Adobe Acrobat versions 6 & 7 as well as Adobe Reader versions 6 & 7 along with ArcGIS version 9 and GeoMedia Version 6, you could have 6 MAP2PDF applications all installed on one machine at the same time, without conflict.

#2006 Why do I receive a message indicating that 0 annotations were loaded?
If your map and shapefile being imported have different projections, the annotations are not imported because the application does not know where to place them. Make sure the projection of your shapefile is the same as the User Coordinate setting within your GeoPDF.

#2007 Why can I only import 5 annotations?
You are working on a trial version of the MAP2PDF for Adobe product. Only 5 annotations are allowed for import until you have purchased and registered a full version of the software.

#2008 Why can I only create and export 5 GeoNotes?
You are working on a trial version of the MAP2PDF for Adobe product. Only 5 GeoNotes are allowed for creation and export until you have purchased and registered a full version of the software.

#2009 What functionality is available with the MAP2PDF for Acrobat product that is NOT available within the GeoPDF Toolbar product?
You have write access to your GeoPDF with MAP2PDF for Acrobat. You can georegister a map, change the coordinate system of an existing map, import annotation and GeoNotes, and export annotation and GeoNotes within MAP2PDF for Acrobat. 

#2010 Why do I no longer see my mini-coordinate display in the lower right corner of my display. 
Either you have turned this option off through the Edit menu > Preferences > Geo2PDF. > GeoPDF Preferences or the map you are looking at could be set to either the unregistered Cartesian, registered Cartesian, or PDF projection parameters. With these specific projections, the mini-coordinate display does not appear. However, units will display if you click on the GeoLocator tool and use the tool's dialog.

#2011 Why do I receive an error message when I try to save coordinate system information to a GeoPDF?
You cannot save changes to a GeoPDF within Adobe Acrobat if you are running a trial version of the software. A full registered version of the software is required to enable this functionality.

#2012 Why is my Request Code non-existent after entering my License Key within the MAP2PDF software activation dialog?
You must have administrative privileges on the machine in order to produce the Request Code. Otherwise, the area will be empty within the activation dialog. Have your system administrator log in and generate the Request Code on your behalf or have your administrator temporarily provide you with administrative privileges to complete the registration process.

#2013 Can I use a GeoPDF to replace an existing PDF or GeoPDF page?
Unfortunately at this time, you cannot replace a GeoPDFpage with another GeoPDF. However, you can insert a new GeoPDF page into a PDF or GeoPDF file and retain the georeferenced information.

